import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "sysstatus get (?!resume).*$\n";
final String string = "sysstatus get resume\n"
+ "sysstatus get idle\n"
+ "sysstatus get talking jhsgdgsdkjfg\n"
+ "sysstatus get ringing\n"
+ "sysstatus get outgoing\n"
+ "sysstatus get sleeping\n"
+ "sysstatus idle\n"
+ "sysstatis talking\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}