re = /sysstatus get (?!resume).*$
/m
str = 'sysstatus get resume
sysstatus get idle
sysstatus get talking jhsgdgsdkjfg
sysstatus get ringing
sysstatus get outgoing
sysstatus get sleeping
sysstatus idle
sysstatis talking
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end