package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^T].*(*SKIP)(*F)|e`)
var str = `The quick brown fox jumps over the lazy dog.
She opened the door.`
var substitution = "3"
fmt.Println(re.ReplaceAllString(str, substitution))
}