// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^T].*(*SKIP)(*F)|e").unwrap();
let string = "The quick brown fox jumps over the lazy dog.
She opened the door.";
let substitution = "3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}