const regex = /&(?!lt|gt|amp|quote|apos)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('&(?!lt|gt|amp|quote|apos)', 'gm')
const str = `a<a
a>a
a'a
a"e;a
a&a
johnson&johnson
J&J
R&D
P&AB
M&ABC
O&ABCD
B&SS-IHC
S&B
GC&E
M&G
P&D`;
const subst = `&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);