import re
regex = re.compile(r"&(?!lt|gt|amp|quote|apos)", flags=re.MULTILINE)
test_str = ("a<a\n"
"a>a\n"
"a'a\n"
"a"e;a\n"
"a&a\n"
"johnson&johnson\n"
"J&J\n"
"R&D\n"
"P&AB\n"
"M&ABC\n"
"O&ABCD\n"
"B&SS-IHC\n"
"S&B\n"
"GC&E\n"
"M&G\n"
"P&D")
subst = "&"
result = regex.sub(subst, test_str)
if result:
print(result)