$re = '/&(?!lt|gt|amp|quote|apos)/m';
$str = 'a<a
a>a
a'a
a"e;a
a&a
johnson&johnson
J&J
R&D
P&AB
M&ABC
O&ABCD
B&SS-IHC
S&B
GC&E
M&G
P&D';
$subst = "&";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;