using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[.|@](company.(fr|com|co.uk)|company2.(fr|com|co.uk)|company3.com)$";
string input = @"arnaud@company.fr
arnaud@company.co.uk
arnaud@company.com
arnaud_company@test.com
companyarnaud@nope.de
arnaud@company.test.com
arnaud@test-company.com
arnaud@company2.fr
arnadu@test.company2.fr
arnaud@company.tests.fr
arnaud@company2.co.uk
arnaud@company3.com
arnaud@company3.com.test.com
arnaud@company.fr.com
arnaud@test.company3.com
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}