import Foundation
let pattern = #"[.|@](company.(fr|com|co.uk)|company2.(fr|com|co.uk)|company3.com)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
arnaud@company.fr
arnaud@company.co.uk
arnaud@company.com
arnaud_company@test.com
companyarnaud@nope.de
arnaud@company.test.com
arnaud@test-company.com
arnaud@company2.fr
arnadu@test.company2.fr
arnaud@company.tests.fr
arnaud@company2.co.uk
arnaud@company3.com
arnaud@company3.com.test.com
arnaud@company.fr.com
arnaud@test.company3.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)