use strict;
my $str = 'arnaud@company.fr
arnaud@company.co.uk
arnaud@company.com
arnaud_company@test.com
companyarnaud@nope.de
arnaud@company.test.com
arnaud@test-company.com
arnaud@company2.fr
arnadu@test.company2.fr
arnaud@company.tests.fr
arnaud@company2.co.uk
arnaud@company3.com
arnaud@company3.com.test.com
arnaud@company.fr.com
arnaud@test.company3.com
';
my $regex = qr/[.|@](company.(fr|com|co.uk)|company2.(fr|com|co.uk)|company3.com)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}