package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+,|,\s+`)
var str = `espn.com,8.8.8.8,nhl.com
yahoo.com, google.com , espn.com `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}