re = /\s+,|,\s+/m
str = 'espn.com,8.8.8.8,nhl.com
yahoo.com, google.com , espn.com '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end