$re = '/\s+,|,\s+/m';
$str = 'espn.com,8.8.8.8,nhl.com
yahoo.com, google.com , espn.com ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);