using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div[^>]*>|(\d{1,9}\.\d{2})";
string input = @"dasdfasdf 355.56 asdfasd
<div class=""sdaf"">sdfsad 36546545643.00 asdfa sdf sadfasdf 544.45 sadfs</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}