re = /<div[^>]*>|(\d{1,9}\.\d{2})/
str = 'dasdfasdf 355.56 asdfasd
<div class="sdaf">sdfsad 36546545643.00 asdfa sdf sadfasdf 544.45 sadfs</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end