package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div[^>]*>|(\d{1,9}\.\d{2})`)
var str = `dasdfasdf 355.56 asdfasd
<div class="sdaf">sdfsad 36546545643.00 asdfa sdf sadfasdf 544.45 sadfs</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}