import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<div[^>]*>|\\G(?!\\A))(?:(?!</div>).)*?\\K\\d{1,9}\\.\\d{2}";
final String string = "dasdfasdf 355.56 asdfasd\n"
+ "<div class=\"sdaf\">sdfsad 36546545643.00 \n"
+ "asdfa sdf sadfasdf 544.45 sadfs</div>\n"
+ "dasdfasdf 355.56 asdfasd";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}