$re = '@(?:<div[^>]*>|\G(?!\A))(?:(?!</div>).)*?\K\d{1,9}\.\d{2}@s';
$str = 'dasdfasdf 355.56 asdfasd
<div class="sdaf">sdfsad 36546545643.00
asdfa sdf sadfasdf 544.45 sadfs</div>
dasdfasdf 355.56 asdfasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);