use strict;
my $str = 'dasdfasdf 355.56 asdfasd
<div class="sdaf">sdfsad 36546545643.00
asdfa sdf sadfasdf 544.45 sadfs</div>
dasdfasdf 355.56 asdfasd';
my $regex = qr@(?:<div[^>]*>|\G(?!\A))(?:(?!</div>).)*?\K\d{1,9}\.\d{2}@sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}