using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\s+\[-\]\s*line:\s+(?<my_log>[^\}]*)";
string input = @"{ [-]
line: 2019-09-27 11:47:29,696 [server] INFO [http-nio-8079-exec-1] [] [] o.s.w.s.DispatcherServlet | Completed initialization in 7 ms
source: stdout
tag: 1445465d0f2e
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}