const regex = /\{\s+\[-\]\s*line:\s+(?<my_log>[^\}]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\s+\\[-\\]\\s*line:\\s+(?<my_log>[^\\}]*)', 'gm')
const str = `{ [-]
line: 2019-09-27 11:47:29,696 [server] INFO [http-nio-8079-exec-1] [] [] o.s.w.s.DispatcherServlet | Completed initialization in 7 ms
source: stdout
tag: 1445465d0f2e
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}