$re = '/\{\s+\[-\]\s*line:\s+(?<my_log>[^\}]*)/m';
$str = '{ [-]
line: 2019-09-27 11:47:29,696 [server] INFO [http-nio-8079-exec-1] [] [] o.s.w.s.DispatcherServlet | Completed initialization in 7 ms
source: stdout
tag: 1445465d0f2e
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);