#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(object)|(: .*)$|^(end)$|^(?! On)( .*)"
Local $sString = "object field: TMemo" & @CRLF & _
" Left = 6" & @CRLF & _
" Top = 23" & @CRLF & _
" Width = 390" & @CRLF & _
" Height = 156" & @CRLF & _
" Anchors = [akLeft, akTop, akRight, akBottom]" & @CRLF & _
" ScrollBars = ssVertical" & @CRLF & _
" TabOrder = 1" & @CRLF & _
" OnChange = fieldChange" & @CRLF & _
" OnKeyUp = fieldKeyUp" & @CRLF & _
" AddMenu = True" & @CRLF & _
" RightClickMoveCaret = True" & @CRLF & _
" RightEdge = 0" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"object btn: TButton" & @CRLF & _
" Left = 5" & @CRLF & _
" Top = 3" & @CRLF & _
" Width = 89" & @CRLF & _
" Height = 21" & @CRLF & _
" Caption = 'Button'" & @CRLF & _
" TabOrder = 0" & @CRLF & _
" TabStop = False" & @CRLF & _
" OnClick = btnClick" & @CRLF & _
"end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")