const regex = /^(object)|(: .*)$|^(end)$|^(?! On)( .*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(object)|(: .*)$|^(end)$|^(?! On)( .*)', 'gm')
const str = `object field: TMemo
Left = 6
Top = 23
Width = 390
Height = 156
Anchors = [akLeft, akTop, akRight, akBottom]
ScrollBars = ssVertical
TabOrder = 1
OnChange = fieldChange
OnKeyUp = fieldKeyUp
AddMenu = True
RightClickMoveCaret = True
RightEdge = 0
end
object btn: TButton
Left = 5
Top = 3
Width = 89
Height = 21
Caption = 'Button'
TabOrder = 0
TabStop = False
OnClick = btnClick
end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}