# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(object)|(: .*)$|^(end)$|^(?! On)( .*)"
test_str = ("object field: TMemo\n"
" Left = 6\n"
" Top = 23\n"
" Width = 390\n"
" Height = 156\n"
" Anchors = [akLeft, akTop, akRight, akBottom]\n"
" ScrollBars = ssVertical\n"
" TabOrder = 1\n"
" OnChange = fieldChange\n"
" OnKeyUp = fieldKeyUp\n"
" AddMenu = True\n"
" RightClickMoveCaret = True\n"
" RightEdge = 0\n"
"end\n\n"
"object btn: TButton\n"
" Left = 5\n"
" Top = 3\n"
" Width = 89\n"
" Height = 21\n"
" Caption = 'Button'\n"
" TabOrder = 0\n"
" TabStop = False\n"
" OnClick = btnClick\n"
"end")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.