package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\s=]+) *= *\S`)
var str = `Is this true car=truck
Is this true car.myCar=truck`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}