$re = '/([^\s=]+) *= *\S/m';
$str = 'Is this true car=truck
Is this true car.myCar=truck';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);