import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\d\\)[^(]+";
final String string = "(4) The Governor-General may arrange\\n with the Chief Minister of the Australian Capital Territory for the variation or revocation of an \\n\\narrangement in force under subsection (3). \\nNorthern Territory \\n (5) The Governor-General may make arrangements with the \\nAdministrator of the Northern \\nTerritory with respect to the ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}