const regex = new RegExp('\\(\\d\\)[^(]+', 'g')
const str = `(4) The Governor-General may arrange\\n with the Chief Minister of the Australian Capital Territory for the variation or revocation of an \\n\\narrangement in force under subsection (3). \\nNorthern Territory \\n (5) The Governor-General may make arrangements with the \\nAdministrator of the Northern \\nTerritory with respect to the `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}