#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\bprostat)(?=\w{0,3}\b))"
Local $sString = "/*ITALIAN*/" & @CRLF & _
"Neoformazione del palato duro in paziente affetto da ca della prostata." & @CRLF & _
"Frustoli agoboptici di parenchima prostatico. " & @CRLF & _
"Il complesso dei reperti orienta in prima ipotesi per localizzazione di carcinoma di origine prostatica." & @CRLF & _
"Agobiopsie prostatiche multiple" & @CRLF & _
"Ipertrofia prostatica." & @CRLF & _
"" & @CRLF & _
"/*ENGLISH*/" & @CRLF & _
"New formation of the hard palate in a patient affected by prostate cancer." & @CRLF & _
"Fragments showing hypertrophic prostate parenchyma." & @CRLF & _
"The combination of findings suggests a preliminary diagnosis of prostate-origin carcinoma." & @CRLF & _
"Multiple prostatic core biopsies." & @CRLF & _
"Prostatic hypertrophy."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")