package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\[([a-f0-9]{1,4}:{1,2}){1,4}([a-f0-9]{1,4})\])(:\d+)?$`)
var str = `[fe80:4049:92ff:fe44:4bd1]:5060`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}