const regex = /^(\[([a-f0-9]{1,4}:{1,2}){1,4}([a-f0-9]{1,4})\])(:\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\[([a-f0-9]{1,4}:{1,2}){1,4}([a-f0-9]{1,4})\\])(:\\d+)?$', 'gm')
const str = `[fe80:4049:92ff:fe44:4bd1]:5060`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}