re = /^(\[([a-f0-9]{1,4}:{1,2}){1,4}([a-f0-9]{1,4})\])(:\d+)?$/m
str = '[fe80:4049:92ff:fe44:4bd1]:5060'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end