import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CsString\\.format\\(.*,\\s*\\[.*\\]\\)";
final String string = "CsString.format(\"Sloto club progress update received: delta = {0}, balance = {1}, type = {2}\", [progress.clubPointsDelta, progress.clubPoints, rewardType)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}