const regex = /CsString\.format\(.*,\s*\[.*\]\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CsString\\.format\\(.*,\\s*\\[.*\\]\\)', 'g')
const str = `CsString.format("Sloto club progress update received: delta = {0}, balance = {1}, type = {2}", [progress.clubPointsDelta, progress.clubPoints, rewardType)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}