$re = '/CsString\.format\(.*,\s*\[.*\]\)/';
$str = 'CsString.format("Sloto club progress update received: delta = {0}, balance = {1}, type = {2}", [progress.clubPointsDelta, progress.clubPoints, rewardType)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);