using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9A-Fa-f]{2}-){5}([0-9A-Fa-f]{2})$";
string input = @"4e-4a-32-33-20-f0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}