$re = '/^([0-9A-Fa-f]{2}-){5}([0-9A-Fa-f]{2})$/';
$str = '4e-4a-32-33-20-f0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);