package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([0-9A-Fa-f]{2}-){5}([0-9A-Fa-f]{2})$`)
var str = `4e-4a-32-33-20-f0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}