package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-g](\(.*?\))?`)
var str = `aba(2)bb(52)gc(4)d(2)fe(14)f(6)g(8)h(4)5(6)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}