$re = '/[a-g](\(.*?\))?/m';
$str = 'aba(2)bb(52)gc(4)d(2)fe(14)f(6)g(8)h(4)5(6)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);