const regex = /[a-g](\(.*?\))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-g](\\(.*?\\))?', 'gm')
const str = `aba(2)bb(52)gc(4)d(2)fe(14)f(6)g(8)h(4)5(6)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}