using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s|\s$|(?<=\B)\s|\s(?=\B)";
string substitution = @"";
string input = @" hello world! , this is Cecy ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}