re = /^\s|\s$|(?<=\B)\s|\s(?=\B)/
str = ' hello world! , this is Cecy '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result