$re = '/^\s|\s$|(?<=\B)\s|\s(?=\B)/';
$str = ' hello world! , this is Cecy ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;