use strict;
my $str = 'comment text is: [{\'type\': \'paragraph\', \'content\': [{\'type\': \'text\', \'text\': \'In conversation with the customer \'}, {\'type\': \'mention\', \'attrs\': {\'id\': \'04445152\', \'text\': \'@Kev\', \'accessLevel\': \'\'}}, {\'type\': \'text\', \'text\': \' Text 123\'}]}]
comment text is: [{\'type\': \'paragraph\', \'content\': [{\'type\': \'text\', \'text\': \'@xyz Text abc\'}]}]
comment text is: [{\'type\': \'paragraph\', \'content\': [{\'type\': \'mention\', \'attrs\': {\'id\': \'3445343\', \'text\': \'@Hey\', \'accessLevel\': \'\'}}, {\'type\': \'text\', \'text\': \' FYI\'}]}]';
my $regex = qr/(?<='text': ')[^']+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}