re = /(?<='text': ')[^']+/m
str = 'comment text is: [{\'type\': \'paragraph\', \'content\': [{\'type\': \'text\', \'text\': \'In conversation with the customer \'}, {\'type\': \'mention\', \'attrs\': {\'id\': \'04445152\', \'text\': \'@Kev\', \'accessLevel\': \'\'}}, {\'type\': \'text\', \'text\': \' Text 123\'}]}]
comment text is: [{\'type\': \'paragraph\', \'content\': [{\'type\': \'text\', \'text\': \'@xyz Text abc\'}]}]
comment text is: [{\'type\': \'paragraph\', \'content\': [{\'type\': \'mention\', \'attrs\': {\'id\': \'3445343\', \'text\': \'@Hey\', \'accessLevel\': \'\'}}, {\'type\': \'text\', \'text\': \' FYI\'}]}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end