$re = '/(?<=\'text\': \')[^\']+/m';
$str = 'comment text is: [{\'type\': \'paragraph\', \'content\': [{\'type\': \'text\', \'text\': \'In conversation with the customer \'}, {\'type\': \'mention\', \'attrs\': {\'id\': \'04445152\', \'text\': \'@Kev\', \'accessLevel\': \'\'}}, {\'type\': \'text\', \'text\': \' Text 123\'}]}]
comment text is: [{\'type\': \'paragraph\', \'content\': [{\'type\': \'text\', \'text\': \'@xyz Text abc\'}]}]
comment text is: [{\'type\': \'paragraph\', \'content\': [{\'type\': \'mention\', \'attrs\': {\'id\': \'3445343\', \'text\': \'@Hey\', \'accessLevel\': \'\'}}, {\'type\': \'text\', \'text\': \' FYI\'}]}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);