using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\s]*b[^\s]*a[^\s]*d[^\s]*w[^\s]*o[^\s]*r[^\s]*d[^\s]*";
string input = @"i'm a badword and test it
tebstadword not ?
What aboua{d|wo}rd ?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}