$re = '/[^\s]*b[^\s]*a[^\s]*d[^\s]*w[^\s]*o[^\s]*r[^\s]*d[^\s]*/m';
$str = 'i\'m a badword and test it
tebstadword not ?
What aboua{d|wo}rd ?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);